ผู้เขียน หัวข้อ: อยากติดตั้ง MySQL5.0  (อ่าน 8161 ครั้ง)

0 สมาชิก และ 1 บุคคลทั่วไป กำลังดูหัวข้อนี้

ออฟไลน์ มดตานอย ครับ..

  • Hero Member
  • *****
  • กระทู้: 3,137
  • Respect: 0
    • ดูรายละเอียด
อยากติดตั้ง MySQL5.0
« เมื่อ: มีนาคม 03, 2007, 02:16:06 AM »
0
อยากติดตั้ง  MySQL5.0  on  linux
1. จะมีไฟล์ติดตั้งของ   mysql  อะไรบ้างครับ
   -   shared    กับ   shared-compat    จะเอาตัวไหนดี
2.และมีที่ไหนใช้   MySQL 5.0   บ้างครับ
3.ดีไหมครับ

Nakhonphanom Hospital

MR.Tanoy999 ผู้ใช้งานทั่วไป
tanoy999-at-gmail-dot-com
เริ่ม  1 ตุลาคม 2549  โดย  BMS

ออฟไลน์ มดตานอย ครับ..

  • Hero Member
  • *****
  • กระทู้: 3,137
  • Respect: 0
    • ดูรายละเอียด
Re: อยากติดตั้ง MySQL5.0
« ตอบกลับ #1 เมื่อ: มีนาคม 03, 2007, 03:26:30 AM »
0
ได้แล้วครับตามนี้
 http://www.itwizard.info/technology/linux/mysql/install_mysql5_fc4.html

Nakhonphanom Hospital

MR.Tanoy999 ผู้ใช้งานทั่วไป
tanoy999-at-gmail-dot-com
เริ่ม  1 ตุลาคม 2549  โดย  BMS

ออฟไลน์ chronoX

  • Sr. Member
  • ****
  • กระทู้: 382
  • Respect: +10
    • ดูรายละเอียด
    • รพ.สมเด็จพระยุพราชท่าบ่อ
Re: อยากติดตั้ง MySQL5.0
« ตอบกลับ #2 เมื่อ: มีนาคม 29, 2007, 20:58:57 PM »
0
ผมขอทราบวิธี upgrade Mysql 4.1 ไปเป็น Mysql 5.0 โดยที่ข้อมูล hosxp ไม่หายครับ
แล้วก้อวิธีตั้งค่าต่างๆ อย่างละเอียดได้มั้ยครับ
ถ้ามีเป็นคู่มือให้ยิ่งดีครับ เพราะต้องการจะเปลี่ยนครับ

ปล.  ถ้าเคยทำได้ จะยิ่งดีครับ
Kreangrit  Pakjinda  Position: Administrator&Programmer @ Thabo Crown Prince Hospital,
Server:OS Linux CenOS 7,RAM 64 Gb HDD 1 TB,Mysql 5.5.31
Slave:OS Linux CenOS 7  Cient:WindowsXP ,7
HOSxP Version 3.59.3.21
http://www.thabohospital.com

ออฟไลน์ por

  • Hero Member
  • *****
  • กระทู้: 1,087
  • เพราะว่าเธอคือดวงใจของฉัน
  • Respect: 0
    • ดูรายละเอียด
    • Blog Adminpor
Re: อยากติดตั้ง MySQL5.0
« ตอบกลับ #3 เมื่อ: มีนาคม 29, 2007, 21:37:23 PM »
0
อ.ครับน่าจะมี ตัว upgrade MySQL 5.x ให้โหลดด้วยนะครับที่อ.แก้ config ไว้แล้วนะครับ

ไม่รู้ว่าจะเป็นการขอมากเกินไปหรือเปล่าครับ

ขอบคุณมากครับ
adminpor
ICT @ Office of Public Health.Nakhonsi Province.
Mobile.083-1740976
Office.075-343409 to 106

doramon

  • บุคคลทั่วไป
Re: อยากติดตั้ง MySQL5.0
« ตอบกลับ #4 เมื่อ: มีนาคม 29, 2007, 22:31:40 PM »
0
เดี่ยวผมหาก่อนเคยทำไว้แล้วหาเจอจะส่งไปให้ครับ
 :) :)

ออฟไลน์ SBR10993

  • Full Member
  • ***
  • กระทู้: 182
  • อะจ๊ากกก..ย่ะ ย่ะ..
  • Respect: +1
    • ดูรายละเอียด
Re: อยากติดตั้ง MySQL5.0
« ตอบกลับ #5 เมื่อ: มีนาคม 29, 2007, 23:46:01 PM »
0
วิธีการก็มีหลายแบบครับ..แล้วแต่ว่าใครจะถนัดแบบไหน อีกทั้งก็ขึ้นอยู่กับจำนวนของข้อมูลเก่าที่มีด้วยว่ามีมากน้อยเพียงใดเพราะนั่นหมายถึงระยะเวลารอคอยในการปรับเปลี่ยนโครงสร้างที่มียาวนานขึ้นนั้นเอง...วิธีการที่ปลอดภัยที่สุด(ที่ผมทำ)ก็คือ หาเครื่องซักเครื่องนึง อาจจะเป็นวินโดว์ก็ได้ ทำ initial import ข้อมูลมาจากเครื่องเซิฟเวอร์จริง จากนั่น ก็เปลี่ยน ไอพีของเครื่องสำรองเป็นไอพีที่ใช้จริง..ในระหว่างนี้อาจจะต้องหยุดเซอร์วิสของมายเอสคิวแอลไว้ซัก แป๊บ...(ยูสเซอร์อาจจะไม่รู้สึก)  แล้วก็เปลี่ยนไอพีของเซอร์เวอร์หลักที่เคยใช้เป็นไอพีอื่น..ไม่งั้นก็จะชนกับไอพีของเครื่องที่เราทำขึ้นใหม่.....เท่านี้ก็จะได้เครื่องไว้ให้บริการผู้ใช้งานแล้ว..และในระหว่างนี้เราก็จะอัพ จากมายเอสคิวแอล 4.1 เป็น 5 ด้วยขั้นตอน

ลีนุกซ์นะครับ...
1.สำรองข้อมูลทั้งหมดในฐานไว้ในเครื่องด้วยคำสั่ง(ถ้ามีหลายดาต้าเบสควรจะมีเหลือไว้แค่เพียงที่ใช้งานจริงฐานเดียวนะครับ)จะได้ไฟล์ เอสคิวแอล 1 ไฟล์ เก็บไว้ที่ /root/mysqldata.sql
mysqldump --opt --single-transaction -A > /root/mysqldata.sql

2.หยุดการใช้งานของมายเอสคิวแอล
service mysql stop

3. พื้นที่ชั่วคราวสำหรับพักข้อมูลในการติดตั้ง
export TMP=/tmp
export TMPDIR=/tmp

4.ลบไฟล์คอนฟิกเดิมออก...พร้อมทั้งเซอร์วิสและข้อมูลเดิม(ก๊อบไฟล์คอนฟิกเดิม my.cnf เอาไว้ก่อนด้วยครับเก็บไว้ที่เดีวกันกับที่เราโหลดไฟล์ อาพีเอ็มมา)
rm -fr /etc/my.cnf
rm -fr /var/lib/mysql
rm -f /etc/init.d/mysql*

5.ติดตั้ง แพคเกจของเวอร์ชั่นใหม่(หาโหลดเอาที่ใกล้เคียงก็ได้ครับ)
rpm -ivh MySQL-shared-compat-5.0.19-0.glibc23.i386.rpm --nodeps --force
rpm -ivh MySQL-client-5.0.19-0.glibc23.i386.rpm --nodeps --force
rpm -ivh MySQL-server-5.0.19-0.glibc23.i386.rpm --nodeps --force

6. หยุดการใช้งานชั่วคราว
service mysql stop

7.ก๊อปปี้ไฟล์คอฟิกกลับคืนสู่ที่เดิมพร้อมทั้งกำหนดสิทธิการเข้าอ่านไฟล์ด้วย 744
cp my.cnf /etc
chmod 744 /etc/my.cnf

8.เร่มการใช้งาน
service mysql start

9. สร้างฐานข้อมูล(แล้วแต่จะตั้งนะครับ.)
mysql -e "drop database if exists DBsbr"
mysql -e "create database DBsbr"
mysql -e "grant all on DBsbr.* to sa@'%' identified by 'sa'"

10.นำข้อมูลเข้าสู่ฐานข้อมูลด้วยคำสั่ง
mysql < /root/mysqldata.sql
หรือ
ใช้การ initial import กลับคืนมาจากเครื่องวินโดว์
จากนั้นรอให้อิมพอร์ตเสร็จ...แล้วก็รัน รีพลิเคชั้นให้ข้อมูลที่ใช้งานในช่วงระหว่างที่เราทำงานเข้ามาที่ฐานตัวใหม่นี้อีกที....เมื่อข้อมูลเท่ากันสองเครื่อง...ก็ควรจะทำการเปลี่ยนไอพีกลับคืนด้วย..เสร็จแล้วครับ.....
********** ลบ ไฟล์ mysqldata.sql  ออกด้วยครับ..เพื่อฟรีฮาร์ดดิสก์
**********ref. อ.ชัยพร ครับ..
หรือจะใช้ตัวอัพเกรดเฮ้วเปอร์ที่ อ เคยทำไว้ก็ได้ครับ..แต่ผมยังไม่ได้ลองตัวนี้..ไฟล์แนบครับ



« แก้ไขครั้งสุดท้าย: มีนาคม 30, 2007, 00:12:20 AM โดย SBR10993 »
Mr.kanchit Pinitmontree
NongBualamphu Prov.Pub.Health
implimented on 14-07-2006 individual

ออฟไลน์ takbai

  • Jr. Member
  • **
  • กระทู้: 84
  • Respect: 0
    • ดูรายละเอียด
Re: อยากติดตั้ง MySQL5.0
« ตอบกลับ #6 เมื่อ: มีนาคม 30, 2007, 01:10:05 AM »
0
อ.ครับน่าจะมี ตัว upgrade MySQL 5.x ให้โหลดด้วยนะครับที่อ.แก้ config ไว้แล้วนะครับ

ไม่รู้ว่าจะเป็นการขอมากเกินไปหรือเปล่าครับ

ขอบคุณมากครับ
 
 
ตากใบ ขอด้ววยครับ  adulbin@hotmail.com
 

ออฟไลน์ juding

  • Jr. Member
  • **
  • กระทู้: 92
  • Respect: 0
    • ดูรายละเอียด
Re: อยากติดตั้ง MySQL5.0
« ตอบกลับ #7 เมื่อ: มีนาคม 30, 2007, 22:48:01 PM »
0
เห็นด้วยอย่างยิ่ง
 

ออฟไลน์ มดตานอย ครับ..

  • Hero Member
  • *****
  • กระทู้: 3,137
  • Respect: 0
    • ดูรายละเอียด
Re: อยากติดตั้ง MySQL5.0
« ตอบกลับ #8 เมื่อ: มีนาคม 30, 2007, 23:12:19 PM »
0
เนื่องจากแต่ละที่ใช้   Mysql4.1  แตกต่างกัน    คือ  บางที่ อาจใช้ สำหรับเครื่อง  cpu  ธรรมดา   หรือ  cpu  64 บิต    และไฟล์ด้วยที่ต่างกัน    บางที่ใช้ไฟล์  ที่เป็น  i386 หรือ   glibc23.i386   หรือ  glibc23.x86_64
ผมกลัวว่าถ้า upgrade  mysql เป็น 5.0   แล้วไฟล์ติดตั้งต่างกันกับตอนแรก  มันจะเกิด  error ขึ้น
มันต้องมีการ  test   ก่อน    นะครับ
ถ้าจะให้ sure ที่สุด    backup   database    เอาไว้  ติดตั้ง server ใหม่  แล้วติดตั้ง MySQL5.x   ใหม่   หรือไม่
ก็ลงแค่  mysql  ใหม่      สามารถ  download  mysql    ที่   www.mysql.com   
หรือ    ftp://ftp.ntu.edu.tw/pub/MySQL/Downloads/MySQL-5.0 
หรือ    ftp://ftp.ntu.edu.tw/pub/MySQL/Downloads/MySQL-5.1
เลือก   packet  ให้ตรงกับ   server นะครับ    ส่วนมาก อ.mn   จะใช้   ตัวที่เป็น glibc23 



         

Nakhonphanom Hospital

MR.Tanoy999 ผู้ใช้งานทั่วไป
tanoy999-at-gmail-dot-com
เริ่ม  1 ตุลาคม 2549  โดย  BMS

doramon

  • บุคคลทั่วไป
Re: อยากติดตั้ง MySQL5.0
« ตอบกลับ #9 เมื่อ: มีนาคม 31, 2007, 07:05:27 AM »
0
*****  ก่อนทำ ต้องสำรองข้อมูลไว้ก่อนนะครับ แล้วนำสิ่งที่สำรองไปทดสอบนำกับมาใช้ด้วยว่าใช้ได้หรือเปล่า

เสร็จแล้วครับวิธีติดตั้ง mysql 5.0.37  แบบ auto ครับเพี่ยงคำสั่งเดี่ยว
แต่ต้องนำไฟล์นี้ไปลงไว้ใน linux แล้วสัั่่ง


sh  automysql5.sh

http://203.157.148.4/webboard/download/automysql5.sh


*****  ก่อนทำ ต้องสำรองข้อมูลไว้ก่อนนะครับ แล้วนำสิ่งที่สำรองไปทดสอบนำกับมาใช้ด้วยว่าใช้ได้หรือเปล่า

ออฟไลน์ มดตานอย ครับ..

  • Hero Member
  • *****
  • กระทู้: 3,137
  • Respect: 0
    • ดูรายละเอียด
Re: อยากติดตั้ง MySQL5.0
« ตอบกลับ #10 เมื่อ: เมษายน 01, 2007, 07:33:02 AM »
0
ต้องต่อ net ด้วยหรือเปล่า   จะมีปัญหาไหน หน้อ

Nakhonphanom Hospital

MR.Tanoy999 ผู้ใช้งานทั่วไป
tanoy999-at-gmail-dot-com
เริ่ม  1 ตุลาคม 2549  โดย  BMS

doramon

  • บุคคลทั่วไป
Re: อยากติดตั้ง MySQL5.0
« ตอบกลับ #11 เมื่อ: เมษายน 02, 2007, 21:41:44 PM »
0
linux  ต้องใช้เน็ตได้ด้วยครับ

ออฟไลน์ chronoX

  • Sr. Member
  • ****
  • กระทู้: 382
  • Respect: +10
    • ดูรายละเอียด
    • รพ.สมเด็จพระยุพราชท่าบ่อ
Re: อยากติดตั้ง MySQL5.0
« ตอบกลับ #12 เมื่อ: เมษายน 02, 2007, 21:59:59 PM »
0
ขอขั้นตอนแบบละเอียดด้วยครับ
Kreangrit  Pakjinda  Position: Administrator&Programmer @ Thabo Crown Prince Hospital,
Server:OS Linux CenOS 7,RAM 64 Gb HDD 1 TB,Mysql 5.5.31
Slave:OS Linux CenOS 7  Cient:WindowsXP ,7
HOSxP Version 3.59.3.21
http://www.thabohospital.com

ออฟไลน์ juding

  • Jr. Member
  • **
  • กระทู้: 92
  • Respect: 0
    • ดูรายละเอียด
Re: อยากติดตั้ง MySQL5.0
« ตอบกลับ #13 เมื่อ: กรกฎาคม 12, 2007, 11:05:17 AM »
0
ตอนนี้ Server ที่โรงพยาบาลใช้ Fedora Core 3 ใช้ Mysql 4.1.1 เห็นว่า Hosxp ตั้งแต่ Version 3.50.3 ขึ้นไป
ต้องใช้ Mysql 5.0 ขึ้นไป ผมเลยต้องการ  Up Mysql  ผมเลยอยากถามดังนี้ครับ
         1. เลือก Mysql 5.0 แบบ Packgack ตัวไหนที่ให้ตรงกับ Fedora Core 3
         2. สามารถ Up Mysql 5.0  ทับ Mysql 4.1.1  ได้เลยไหมครับ
         3. ตัว Upgrad Mysql Auto ของอาจารย์อ๊อดให้มา ใช้ไงครับ
         4. ถ้าเรายังใช้ Mysql 4.1.1  แล้ว Upgrad Version 3.50.3 ขึ้นไป จะมีปัญหาต่อระบบมากไหมครับ
             คำถามนี้หลายโรงพยาบาลอยากรู้มากครับ
         ขอบคุณผู้รู้ทุกท่านมากน่ะครับ